Migration bug thread

Discussion in 'Forum News / Announcements' started by goldpelican, Oct 13, 2012.

  1. Macros_The_Black

    Macros_The_Black Member Silver Stacker

    Joined:
    Nov 15, 2011
    Messages:
    606
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    The Interwebz
    New Posts being mysteriously reset.

    On 3 occasions now I've come back to SS with a page of a sub-forum showing "new posts" - but on a different device (eg iPad, iPhone) the slate has been wiped clean as if the "Mark all topics as read" has been clicked (when I KNOW I've got posts waiting to be read).

    On this occasion, I was interrupted while on the iPhone, so left the "new posts" page up to come back to, without touching a thing.

    By the time I'd been able to get to SS, I'm now on the laptop and simply refreshed the entire site (to obtain all new posts) .... only to find, as above, no new posts at all.

    OK I thought, maybe it's now device-specific (eg before if you use the "Mark all topics as read" function it will record your "all read" date-stamp in the db no matter where you login from, whereas a simple click on the post will mark it as "read" on that device only), so I went back to the iPhone to read the "new posts" that I'd left up there, refreshed the page and see no new posts at all.

    So my conclusion is that the user-session is somehow being randomly re-set?

    Anyone else experiencing this? (Only just recently, so I wonder if the recent CloudFront deployment is affecting this with local db caching/purging? I'm currently in the UK if that helps or hinders)

    Cheers,

    M_T_B
     
  2. goldpelican

    goldpelican Administrator Staff Member

    Joined:
    Jun 29, 2009
    Messages:
    17,893
    Likes Received:
    289
    Trophy Points:
    83
    Cloudfront is purely caching images - haven't experienced that myself yet.
     
  3. bordsilver

    bordsilver Well-Known Member Silver Stacker

    Joined:
    May 23, 2012
    Messages:
    9,618
    Likes Received:
    315
    Trophy Points:
    83
    Location:
    The rocks
    Strange things like Macros say have been happening recently. I regularly switch between 4 devices/computers and the read/unread topics are behaving differently recently.

    I wouldn't say it is a "bad thing" per se, just "a thing".
     

Share This Page